当前位置:主页 > www3499C0m正文

www3499C0m:路由封BT的终极几种方法

05月07日作者:黑曼巴


第一种是常用的封端口的措施:

呵呵,常用的敕令如下:

禁止∶

access-list 102 deny tcp any any range 6881 6890

access-list 102 denywww3499C0m tcp any range 6881 6890 any

access-list 102 permit ip any any

这种措施有其局限性,一是现在有的bt软件,再封锁后会自动改端口二是我仔细钻研过好几个BT下载软件,它们现在的announce端口现在已经用8000、8080的说,假如连这个www3499C0m也封,那收集应用就有可能不正常(我这样做过,呵呵,后来N 多人打电话找我,吓得我顿时DEL 掉落了)

第二种措施:便是用NBAR(Network-Based Application Recognition )收集利用识别NBAR是一种动态能在四到七层探求协议的技巧,它不只能做到通俗ACL能做到那样节制静态的TCP UDP 的报,也能做到节制一样平常ACLs不能做到动态的端口的那些协议(如BT)之类。

An external Packet Description Language Module(PDLM)的文件用来扩展NBAR识别的协议。(详细我也翻译不出来,只看了个大年夜概),

我就说说历程:1 、到http://www.cisco.com/pcgi-bin/tablebuild.pl/pdlm下载bittorrent.pdlm ,(要CCO 的)

2 、放到TFTP,然后用copy tftp disk2 (大年夜多半应该是flash )

#show runn

获得关于BT的部分是

class-map match-all bittorrent

match protocol bittorrent

!

!

policy-map bittorrent-policy

class bittorrent

drop

!

interface GigabitEthernet0/2

description CONNECT INSIDE

ip address 192.168.168.1 255.255.255.252 secondary

ip address 192.168.21.1www3499C0m 255.255.255.0

ip nat inside

service-policy input bittorrent-policwww3499C0my

service-policy output bittorrent-policy

duplex full

speed 1000

media-type rj45

no negotiation auto

对付Emule ,最新verwww3499C0msion2.0的包括了emule ,可我实验了一下,切实着实可以:

ip nbar pdlm bittorrent.pdlm

ip nbar pdlm eDonkey.pdlm

class-map match-any bittorrent

match protocol bittorrent

match protocol edonkey

!

!

policy-map bittorrent-policy

class bittorrent

drop

!

这样的话,Emule 也能K 掉落了,呵呵!

最近关注

热点内容

更多